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Although cloud-based solutions and budget apps are trying to steal Excel’s thunder, it still remains the king of accounting, charting and data organization. With millions of people worldwide using MS Excel, many forget to utilize its formidable security feature: adding passwords and making it read-only. This will ensure that the only people who can
tamper with your spreadsheet are those you give express permission to do so, locking customization of your sheet behind a secure encrypted password. Here’s how to do it. Why Lock an Excel Workbook Protecting an Excel workbook with a password can work in two ways: Prevent unauthorized access to the workbookRestrict users from modifying the
contents of the spreadsheet (makes it read only) In both instances, you can protect an Excel workbook with a password to make it read only. This means users will be able to open the workbook and view the data but won’t be able to make any changes to the spreadsheet. This is vitally important if you are running a small to medium-sized business and
want to ensure the integrity of your financial data. How to Save an Excel Workbook as Read Only Here’s a step-by-step guide on how to lock an Excel spreadsheet or workbook with a password and make it read only. Open the workbook you want to safeguard. Go to “File -> Save As” option in the menu. Next, click “Browse” to bring up the “Save As”
dialogue box. In the “Save as type” dropdown, make sure you’re using a proprietary Excel format (Excel Workbook, Excel 97-2003 Workbook, Excel Add-in etc.), otherwise the password protection feature in the next step will be greyed out. At the bottom of the box, click “Tools” option just next to the “Save” button. Click on “Tools” and a drop-down
menu will open. Select and click “General options” in the drop-down menu. Enter your desired password in the “Password to modify” box as illustrated below. If you have a password manager already installed, you can use it to generate a strong password for you and store it in the vault. Otherwise, you can use this guide on how to generate hard-tocrack passwords. With the password secured, check the box for “Read-Only recommended,” then click “OK.” You’ll be prompted to confirm the password. Enter the same password, then click OK to complete the process. Lastly, click the “Save” button. Now, every time a user attempts to open the workbook, a pop-up notification box will appear with
the following message. Clicking the “Read-Only” button will open the document but in Read-Only mode. Only those you share the “password to modify” with will be able to make changes to the workbook. How to Unprotect an Excel Workbook What if you want to lift the read-only restriction and grant everyone editing privileges? Removing the ReadOnly feature is an easy process and can be done with just a click of a button. All you’ll need to do is go through the same process again and uncheck the box that makes your Excel workbook Read-Only. Click on “File -> Save As” and in the dialogue box that shows up, select “General Options” from the “Tools” dropdown menu next to the “Save”
button.Uncheck the “Read-Only recommended” box. Remove the password that you had set and click “Save” to apply the new changes. The next time you open the workbook, it will not open in Read-Only mode, nor will it display the Read-Only restriction box. Frequently Asked Questions The best workaround to this is to copy all the data from the
original workbook into a new one, then save the new workbook with a password that you actually remember. Note that this will only work at the “read-only” password level, not if you’ve set a password for the entire workbook. Since MS Office 2016, 256-bit AES protection has been integrated, upgrading from the old 128-bit encryption, which makes
modern Excel comparable to dedicated password managers. Say you want someone having read-only access to a workbook, but you only want them to see certain data in it; the best way to moderate this is by right-clicking the rows or columns you want to hide, then click “Hide.” To reveal the columns again, highlight the columns either side of the
hidden one, right-click at the top, then click “Unhide.” Take Advantage of Excel File Encryption Setting a password in Excel to protect any workbook is easy and self-explanatory. Nevertheless, it can give a great deal of control over who can access and/or edit a workbook. This can go a long way in maintaining data integrity. Now that you know how to
make your Excel workbook Read-Only, the next things you can learn are using the Concatenate function and how to split cells in Excel. We also have a couple of Word tutorials for you – learn how to display one page at a time and how to add offline videos to Word documents. Is this article useful? This example shows you how to make your Excel
workbook read-only. Users can still save changes by creating a new copy of the workbook. For a better protection, protect a sheet. 1. Open a workbook. 2. On the File tab, click Save As. 3. Click Browse. 4. Click on the Tools button and click General Options. 5. In the Password to modify box, enter a password and click OK. Note: If you only want to
recommend users to open the Excel file as read-only, without protecting it, don't enter a password and check Read-only recommended. 6. Reenter the password and click on OK. Note: this feature does not encrypt your Excel file. Malicious users can edit the file and remove the password. 7. Enter a file name and click Save. Your workbook is read-only
now. The password for the downloadable Excel file is "easy". Something went wrong. Wait a moment and try again. If you have been working with Microsoft apps (such as Excel, PowerPoint, or Word), I am sure you have encountered files that are read-only. What a read-only file means is that it’s only supposed to be read, and not be edited. So if you
make a file read-only (and the user opens it as a read-only file), they won’t be able to make any changes to the original file. In this tutorial, I will cover how to make an Excel file read-only, all the options a user gets when opening a read-only file, and how to remove the read-only property from an Excel file. Create Read Only Excel File You’ve probably
created a lot of Excel files that you need to share with other users, but don’t want it to be changed. If you make a file read-only, other users will have access to it, but all changes will have to be saved in the new file. Therefore, the original file will be untouched. This way you can be sure that your file will be the same despite sharing it with other
colleagues (especially if that file is on a network drive where multiple people can change it). Let’s now see how to save an Excel file and protect it as read-only. This option can be activated during the saving of the file. In the ribbon, go to the File tab. In the menu on the left side, choose Save As. In the Browse window, click on Tools and choose
General Options. In the General Options window, you need to check Read-only recommended and click OK. Now you’re back in the Browse window, and just click Save button to save the file and read-only settings. Finally, you saved your file as a read-only Excel document. Let’s now see what happens when you open the file and try to edit it. One thing
you need to remember is that when you make a file read-only, the user can still open the original file and make changes to it (they just need to decline the option to open the file as read-only). So if you’re doing this to make sure no one changes the original file, be informed that this is not a fool-proof way. What Happens when You Open a Read Only
File? If you try to open the previously saved read-only file, you will get the following prompt: Excel notifies you that the file you’re opening is read-only and asks you if you want to open it as read-only or not. Possible answers here are: Yes – if you select Yes, the file will be opened in the read-only mode, which means that you will have to save it as new
file (with a different name) in order to save your changesNo – if you choose No, the file will open as a regular Excel file (not in read-only mode), and you’ll be able to make changes to the original file and save itCancel – if you choose to cancel, it will close the file As you can conclude from the previous explanation, the read-only feature doesn’t actually
protect your workbook. This option just notifies a user that you don’t want the original file to be changed. However, if a user doesn’t choose to open as read-only, the file can be changed normally. So, if you want to be sure that your file is secured and not changed, you need to password protect it. On the other side, the read-only option is just a
notification for other users. One scenario where making the file read-only helps is when you don’t want yourself or any other user to make any changes in the file inadvertently. So if you only want to read the file (and it has been saved as read-only), it’s better to open it as read-only. This way, even if you make some changes and hit the save button, it
will save it as a separate file. Changing a Read Only File If you select yes when opening a file (which means that you opened the file as read-only), you will have to save it as a new file after making any changes. When you open a read-only file, you can see at the top of the file (next to the name) that the file is read-only. Once you’re done with the
changes and want to save the file, click the save icon or press CTRL + S on the keyboard to save the file. The warning message pops up, with the information that you can’t change the read only file and have to save it as a new file with a different name or in a different location. When you press OK, the Save As window will appear. Here you have to
give a new name to the file or go to Browse and select a new file location to save it. As a result, the original file remains unchanged, while the changes you made are saved in a new file that you created. Removing Read-Only Option from a File If you don’t need your file to be read-only anymore, you can easily remove a read-only option from the file
and make it editable again. In order to do this, you have to follow similar steps to creating a read-only file. First, you need to open the file as editable, not read only. When you open the read only file, Excel will ask you if you want to open it as read only, and you have to click No. In the ribbon, go to the File tab. In the menu on the left side, choose
Save As. In the Browse window, click on Tools and choose General Options. In the General Options window, you need to uncheck Read-only recommended and click OK. Now you’re back in the Browse window, and just click the Save button to save the file. Finally, you saved your file without the read-only feature. If you open it again, you will be able
to change it and save, without any restrictions or warnings. Conclusion As you saw in the article, making an Excel file read-only, can help you to prevent unwanted changes to your file. However, this feature can’t stop a user from changing your file. It will only give a warning, that a file is read-only, and shouldn’t be changed. You must keep in mind
that a user can always choose to ignore a warning. Furthermore, the file doesn’t need to be opened as a read-only and in that case, it can be easily changed and saved. So, if you need to protect your file from changes and want to be sure that it won’t be changed, you need to use password protection. Every read-only file has the information next to the
name on the top when it’s opened, that you’re working in a read-only file. When changing this kind of file, all changes have to be saved in a new file with a new name, or in a different location on a computer. If you want to remove a read-only attribute from a file, you need to open it not as a read-only, but as an editable file. This way, you can use the
same steps as for creating a read-only file to remove this feature. All of this, you need to do during the saving of a file. I hope you found this tutorial useful! Other Excel tutorials you may also like:
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